SuperTux Bug Tracker
SuperTux logo


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000211supertux-editorBuilding/Installationpublic2007-05-02 10:282010-04-19 00:36
Reporterjan 
Assigned ToAnMaster 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionunable to reproduce 
Platformx86-64 (AMD 64 X2)OSopenSUSEOS Version10.2
Product Version 
Target VersionFixed in Version 
Summary0000211: supertux editor does'nt start
DescriptionWhen I start supertux editor from the K-Menu there is nothing, no error message.

If I start supertux editor from the console it says:
linux-jan:~ # supertux-editor

** (/usr/bin/supertux-editor.exe:14001): WARNING **: The following assembly referenced from /usr/bin/supertux-editor.exe could not be loaded:
     Assembly: gtk-sharp (assemblyref_index=0)
     Version: 2.10.0.0
     Public Key: 35e10195dab3c99f
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/bin).


** (/usr/bin/supertux-editor.exe:14001): WARNING **: Could not load file or assembly 'gtk-sharp, Version=2.10.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' or one of its dependencies.

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'gtk-sharp, Version=2.10.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f' or one of its dependencies.
File name: '03y'

I tried it with gtkgl-sharp.dll renamed to gtk-sharp.dll and it says:
linux-jan:~ # supertux-editor

** (/usr/bin/supertux-editor.exe:14436): WARNING **: The class Gtk.Window could not be loaded, used in gtk-sharp, Version=2.10.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f
Stacktrace:


Native stacktrace:

        mono [0x51c7d5]
        mono [0x4e9d7f]
        /lib64/libpthread.so.0 [0x2ba9cc678130]
        mono(mono_class_vtable+0x34d) [0x49b82d]
        mono(mono_object_new+0x9) [0x49d059]
        mono(mono_exception_from_name_two_strings+0x55) [0x4af295]
        mono [0x497de8]
        mono [0x4c04d4]
        mono(mono_class_vtable+0xcd) [0x49b5ad]
        mono(mono_object_new+0x9) [0x49d059]
        mono(mono_exception_from_name_two_strings+0x55) [0x4af295]
        mono [0x4c05d7]
        mono(mono_class_vtable+0xcd) [0x49b5ad]
        mono [0x50827d]
        mono(mono_runtime_invoke+0xa) [0x4992aa]
        mono(mono_runtime_exec_main+0x68) [0x49c498]
        mono(mono_runtime_run_main+0x16a) [0x49ca1a]
        mono(mono_main+0x962) [0x414b72]
        /lib64/libc.so.6(__libc_start_main+0xf4) [0x2ba9ccaf9ae4]
        mono(g_ascii_strcasecmp+0x42) [0x413caa]

Debug info from gdb:

(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 48008288960512 (LWP 14436)]
[New Thread 1075988800 (LWP 14438)]
[New Thread 1073822016 (LWP 14437)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00002ba9ccb97302 in __select_nocancel () from /lib64/libc.so.6
  3 Thread 1073822016 (LWP 14437) 0x00002ba9cc677751 in __nanosleep_nocancel
    () from /lib64/libpthread.so.0
  2 Thread 1075988800 (LWP 14438) 0x00002ba9cc674746 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
  1 Thread 48008288960512 (LWP 14436) 0x00002ba9ccb97302 in __select_nocancel
    () from /lib64/libc.so.6

Thread 3 (Thread 1073822016 (LWP 14437)):
#0 0x00002ba9cc677751 in __nanosleep_nocancel () from /lib64/libpthread.so.0
0000001 0x00000000004c476a in mono_once ()
0000002 0x00002ba9cc67009e in start_thread () from /lib64/libpthread.so.0
0000003 0x00002ba9ccb9d4cd in clone () from /lib64/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 2 (Thread 1075988800 (LWP 14438)):
#0 0x00002ba9cc674746 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
0000001 0x00000000004cd84a in mono_pthread_key_for_tls ()
0000002 0x00000000004cd96e in mono_pthread_key_for_tls ()
0000003 0x00000000004cdaed in mono_pthread_key_for_tls ()
0000004 0x00000000004d10b2 in mono_pthread_key_for_tls ()
0000005 0x000000000052201f in mono_gc_is_finalizer_thread ()
0000006 0x000000000047792d in mono_thread_detach ()
0000007 0x00000000004c89a7 in mono_pthread_key_for_tls ()
0000008 0x00000000004dfcb7 in GC_start_blocking ()
0000009 0x00002ba9cc67009e in start_thread () from /lib64/libpthread.so.0
0000010 0x00002ba9ccb9d4cd in clone () from /lib64/libc.so.6
0000011 0x0000000000000000 in ?? ()

Thread 1 (Thread 48008288960512 (LWP 14436)):
#0 0x00002ba9ccb97302 in __select_nocancel () from /lib64/libc.so.6
0000001 0x00002ba9cc21ce3f in g_spawn_sync ()
   from /opt/gnome/lib64/libglib-2.0.so.0
0000002 0x00002ba9cc21d208 in g_spawn_command_line_sync ()
   from /opt/gnome/lib64/libglib-2.0.so.0
0000003 0x000000000051c83a in mono_walk_stack ()
0000004 0x00000000004e9d7f in mono_jit_thread_attach ()
0000005 <signal handler called>
0000006 0x000000000049b82d in mono_class_vtable ()
0000007 0x000000000049d059 in mono_object_new ()
0000008 0x00000000004af295 in mono_exception_from_name_two_strings ()
0000009 0x0000000000497de8 in mono_lookup_pinvoke_call ()
0000010 0x00000000004c04d4 in mono_type_get_name ()
0000011 0x000000000049b5ad in mono_class_vtable ()
0000012 0x000000000049d059 in mono_object_new ()
0000013 0x00000000004af295 in mono_exception_from_name_two_strings ()
0000014 0x00000000004c05d7 in mono_type_get_name ()
0000015 0x000000000049b5ad in mono_class_vtable ()
0000016 0x000000000050827d in mono_jit_thread_attach ()
0000017 0x00000000004992aa in mono_runtime_invoke ()
0000018 0x000000000049c498 in mono_runtime_exec_main ()
0000019 0x000000000049ca1a in mono_runtime_run_main ()
0000020 0x0000000000414b72 in mono_main ()
0000021 0x00002ba9ccaf9ae4 in __libc_start_main () from /lib64/libc.so.6
0000022 0x0000000000413caa in g_ascii_strcasecmp ()
0000023 0x00007fffdef0b0a8 in ?? ()
0000024 0x0000000000000000 in ?? ()
#0 0x00002ba9ccb97302 in __select_nocancel () from /lib64/libc.so.6


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted

The supertux game works.
Have I anything done wrong?
TagsNo tags attached.
Fixed in GIT revision
Fixed in subversion revision
Attached Files

- Relationships
related to 0000224closedAnMaster Can't start the Editor 

-  Notes
(0000479)
sommer (administrator)
2007-05-02 12:42

The editor is complaining that it cannot find the assembly "gtk-sharp".

You might be missing the assembly "gtk-sharp".

OpenSuSE seems to have a package "gtk-sharp" - it might contain the missing assembly, but I'm not sure.

Could you check if you have that one installed?
(0000480)
jan (reporter)
2007-05-04 05:23

Yes, I have installed gtk-sharp, but supertux-editor needs gtk-sharp-2.10.0 which doesn't work because of the dependencies (There are errors if I wanto to install the dependencies.
(0000481)
jan (reporter)
2007-05-04 07:31

It worked after copying the following files into the supertux-editor folder:
/usr/lib/mono/gac/gtk-sharp/2.8.0.0__xxxxxxxxxxxxxxxx/gtk-sharp.dll
/usr/lib/mono/gac/gtk-sharp/2.8.0.0__xxxxxxxxxxxxxxxx/gtk-sharp.dll.config
/usr/lib/mono/gac/glade-sharp/2.8.0.0__xxxxxxxxxxxxxxxx/glade-sharp.dll
/usr/lib/mono/gac/glade-sharp/2.8.0.0__xxxxxxxxxxxxxxxx/glade-sharp.dll.config
/usr/lib/mono/gac/gdk-sharp/2.8.0.0__xxxxxxxxxxxxxxxx/gdk-sharp.dll
/usr/lib/mono/gac/gdk-sharp/2.8.0.0__xxxxxxxxxxxxxxxx/gdk-sharp.dll.config
(0000482)
jan (reporter)
2007-05-04 07:35

I forgot to write that
/usr/lib/mono/gac/glib-sharp/2.8.0.0__xxxxxxxxxxxxxxxx/glib-sharp.dll
and
/usr/lib/mono/gac/glib-sharp/2.8.0.0__xxxxxxxxxxxxxxxx/glib-sharp.dll.config
have to be copied too.
(0000550)
AnMaster (administrator)
2007-06-13 10:01

marking bug as resolved - unable to reproduce

- Issue History
Date Modified Username Field Change
2007-05-02 10:28 jan New Issue
2007-05-02 12:42 sommer Note Added: 0000479
2007-05-02 23:07 AnMaster Status new => feedback
2007-05-02 23:07 AnMaster Issue Monitored: AnMaster
2007-05-04 05:23 jan Note Added: 0000480
2007-05-04 07:31 jan Note Added: 0000481
2007-05-04 07:35 jan Note Added: 0000482
2007-06-13 10:00 AnMaster Relationship added related to 0000224
2007-06-13 10:01 AnMaster Note Added: 0000550
2007-06-13 10:01 AnMaster Assigned To => AnMaster
2007-06-13 10:01 AnMaster Status feedback => resolved
2007-06-13 10:01 AnMaster Resolution open => unable to reproduce
2008-01-24 10:39 sik0fewl Status resolved => closed
2010-04-19 00:36 mattmccutchen2 Product Version 0.3.0 =>


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker