SuperTux Bug Tracker
SuperTux logo


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000410supertuxBuilding and Installationpublic2008-10-12 14:222012-09-08 05:59
ReporterGrondin 
Assigned Tomathnerd314 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionno change required 
PlatformDEBIANOSLinuxOS Version2.6.26.6
Product Version0.3.2-SVN 
Target VersionFixed in Version 
Summary0000410: Impossible to compile supertux
DescriptionAfter running cmake.. in build/ directory, the compilation with make fails :

 make
-- Found OggVorbis: /usr/lib/libvorbisenc.so;/usr/lib/libvorbisfile.so;/usr/lib/libvorbis.so;/usr/lib/libogg.so
-- Size of void* is 4
-- Configuring done
-- Generating done
-- Build files have been written to: /home/bertrand/supertux/build
Scanning dependencies of target squirrel
[ 0%] Building CXX object src/squirrel/CMakeFiles/squirrel.dir/squirrel/sqfuncstate.o
In file included from <command-line>:0:
/home/bertrand/supertux/build/config.h:5:25: warning: missing terminating " character
In file included from <command-line>:0:
/home/bertrand/supertux/build/config.h:7: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:7: error: stray ‘\251’ in program
/home/bertrand/supertux/build/config.h:7: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:7: error: stray ‘\264’ in program
/home/bertrand/supertux/build/config.h:8: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:8: error: stray ‘\251’ in program
/home/bertrand/supertux/build/config.h:8: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:8: error: stray ‘\264’ in program
/home/bertrand/supertux/build/config.h:8:19: error: exponent has no digits
/home/bertrand/supertux/build/config.h:8:38: error: invalid suffix "ca" on integer constant
/home/bertrand/supertux/build/config.h:9: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:9: error: stray ‘\251’ in program
/home/bertrand/supertux/build/config.h:10: error: stray ‘\305’ in program
/home/bertrand/supertux/build/config.h:10: error: stray ‘\223’ in program
/home/bertrand/supertux/build/config.h:10: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:10: error: stray ‘\251’ in program
/home/bertrand/supertux/build/config.h:11: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:11: error: stray ‘\242’ in program
/home/bertrand/supertux/build/config.h:11: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:11: error: stray ‘\251’ in program
/home/bertrand/supertux/build/config.h:12: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:12: error: stray ‘\250’ in program
/home/bertrand/supertux/build/config.h:13: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:13: error: stray ‘\251’ in program
/home/bertrand/supertux/build/config.h:13: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:13: error: stray ‘\250’ in program
/home/bertrand/supertux/build/config.h:14: error: stray ‘\303’ in program
/home/bertrand/supertux/build/config.h:14: error: stray ‘\250’ in program
/home/bertrand/supertux/build/config.h:14:79: warning: missing terminating " character
/home/bertrand/supertux/build/config.h:14: error: missing terminating " character
/home/bertrand/supertux/build/config.h:6: error: function definition does not declare parameters
make[2]: *** [src/squirrel/CMakeFiles/squirrel.dir/squirrel/sqfuncstate.o] Erreur 1
make[1]: *** [src/squirrel/CMakeFiles/squirrel.dir/all] Erreur 2
make: *** [all] Erreur 2
Steps To Reproducemkdir build
cd build
cmake ..
make
TagsAttachedFiles
Fixed in GIT revision
Fixed in subversion revision
Attached Filestxt file icon CMakeCache.txt (Attachment missing)

- Relationships

-  Notes
(0001087)
lsz (reporter)
2008-10-12 18:16

I see this bug too.
this is because of the #define PACKAGE_VERSION in config.h
I see a lot of Chinese here (I use Chinese locale)
it's about the same with `svn info`
perhaps there's something wrong in getting svn version number.
(0001088)
mathnerd314 (administrator)
2008-10-12 19:49

Please post revision number, config.h (in build directory), and CMakeCache.txt files.
(0001090)
Grondin (reporter)
2008-10-13 07:13

my config.h file bellow :

#ifndef CONFIG_H
#define CONFIG_H

#define PACKAGE_NAME "supertux"
#define PACKAGE_VERSION "0.3.2-SVN rChemin : /home/bertrand/supertux
URL : http://supertux.lethargik.org/svn/supertux/trunk/supertux [^]
Racine du dépôt : http://supertux.lethargik.org/svn/supertux [^]
UUID du dépôt : 837edb03-e0f3-0310-88ca-d4d4e8b29345
Révision : 5795
Type de nœud : répertoire
Tâche programmée : normale
Auteur de la dernière modification : mathnerd314
Révision de la dernière modification : 5795
Date de la dernière modification: 2008-10-06 04:19:19 +0200 (lun 06 oct 2008)"

/* #undef DEBUG */
/* #undef ENABLE_SQDBG */

/* #undef ENABLE_BINRELOC */
#define APPDATADIR "/usr/local/share/games/supertux2"

#define SIZEOF_VOID_P 4
#if SIZEOF_VOID_P == 8
#define _SQ64
#endif

/* #undef HAVE_ICONV_CONST */
#ifdef HAVE_ICONV_CONST
#define ICONV_CONST const
#else
#define ICONV_CONST
#endif

/* #undef WORDS_BIGENDIAN */

#define HAVE_OPENGL

#define HAVE_LIBCURL

//Useful constants
static const float DELTA = .0001f;

// the engine will be run with a logical framerate of 64fps.
// We chose 64fps here because it is a power of 2, so 1/64 gives an "even"
// binary fraction...
static const float LOGICAL_FPS = 64.0;


#endif /*CONFIG_H*/
(0001091)
mathnerd314 (administrator)
2008-10-14 15:30

It seems to be the result of localized Subversion; it's actually, as might be guessed, a CMake bug rather than a SuperTux bug.

There's a bug in their tracker (http://www.cmake.org/Bug/view.php?id=5492 [^]) and a fix in the latest CVS:
http://www.cmake.org/cgi-bin/viewcvs.cgi/*checkout*/Modules/FindSubversion.cmake?root=CMake [^]

Try backing up and overwriting your FindSubversion.cmake file with this one. (Should be in usr/share/cmake-2.x/modules or so)
(0001502)
mathnerd314 (administrator)
2010-01-17 16:20

Fixed upstream in CMake.

- Issue History
Date Modified Username Field Change
2008-10-12 14:22 Grondin New Issue
2008-10-12 18:16 lsz Note Added: 0001087
2008-10-12 19:49 mathnerd314 Note Added: 0001088
2008-10-13 07:11 Grondin File Added: CMakeCache.txt
2008-10-13 07:13 Grondin Note Added: 0001090
2008-10-13 07:16 Grondin Issue Monitored: Grondin
2008-10-13 07:16 Grondin Issue End Monitor: Grondin
2008-10-14 15:30 mathnerd314 Note Added: 0001091
2010-01-17 16:20 mathnerd314 Note Added: 0001502
2010-01-17 16:20 mathnerd314 Status new => resolved
2010-01-17 16:20 mathnerd314 Resolution open => no change required
2010-01-17 16:20 mathnerd314 Assigned To => mathnerd314
2011-10-22 15:30 sik0fewl Status resolved => closed
2012-09-08 05:59 superdev Tag Attached: AttachedFiles


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker