SuperTux Bug Tracker
SuperTux logo


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000359supertuxGameplaypublic2008-06-09 21:012013-09-14 14:38
Reportersebasmagri 
Assigned Tosik0fewl 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
Platformx86_64 (AMD64, 64-bit)OSLinuxOS Version2.6
Product Version0.3.2-SVN 
Target VersionFixed in Version0.3.3 
Summary0000359: Crash in Dungeon Island, Going Down World.
DescriptionAN ERROR HAS OCCURED [the index 'way4' does not exist]

CALLSTACK
*FUNCTION [main()] ScriptTrigger line [1]

LOCALS
[this] TABLE
Fatal: Unexpected exception: Squirrel error: Couldn't start script (the index 'way4' does not exist)
Steps To ReproduceOpen the game and select the Dungeon Island, Going Down World.
Play for a while and get it crashed...
Additional InformationBuilt with GCC-4.3.1 and glibc-2.8 on a Gentoo System...
TagsNo tags attached.
Fixed in GIT revision
Fixed in subversion revision5561
Attached Files

- Relationships
has duplicate 0000372closedmathnerd314 Game Crashes during Dungeon Island, first level. 

-  Notes
(0000906)
MMlosh (administrator)
2008-06-10 08:22

For me it crasehes with AN ERROR HAS OCCURED [the index 'way1' does not exist]
This file can be just under developtment, I have no idea how "Check online" works.
(0000907)
MMlosh (administrator)
2008-06-10 08:54

I was wrong, nothing changed in this level, file "supertux/data/images/objects/platforms/pedestral.sprite" is empty since r5544.
(0000913)
sebasmagri (reporter)
2008-06-12 22:25

It's still crashing with:

AN ERROR HAS OCCURED [the index 'way1' does not exist]

CALLSTACK
*FUNCTION [main()] ScriptTrigger line [1]

LOCALS
[this] TABLE
Fatal: Unexpected exception: Squirrel error: Couldn't start script (the index 'way1' does not exist)

On revision 5567...
(0000917)
sik0fewl (administrator)
2008-06-13 13:10
edited on: 2008-06-13 13:11

Ok, I'll take a closer look at it.

Where can this level be found?

(0000937)
mathnerd314 (administrator)
2008-07-16 13:10

It's an addon; you could probably just open it up;
URL is http://www.deltadevelopment.de/users/christoph/supertux/addons/dungeon_island.zip [^]

Try changing pedestral to pedestal in the file; it probably is at least somewhat the cause of it.
(0003519)
lmh (administrator)
2013-09-14 14:38

This doesn't appear to be an issue anymore in the recent download of the add-on.

- Issue History
Date Modified Username Field Change
2008-06-09 21:01 sebasmagri New Issue
2008-06-10 08:22 MMlosh Note Added: 0000906
2008-06-10 08:54 MMlosh Note Added: 0000907
2008-06-12 12:45 sik0fewl Fixed in subversion revision => 5561
2008-06-12 12:45 sik0fewl Status new => resolved
2008-06-12 12:45 sik0fewl Fixed in Version => 0.3.2-SVN
2008-06-12 12:45 sik0fewl Resolution open => fixed
2008-06-12 12:45 sik0fewl Assigned To => sik0fewl
2008-06-12 22:25 sebasmagri Note Added: 0000913
2008-06-13 13:10 sik0fewl Note Added: 0000917
2008-06-13 13:10 sik0fewl Status resolved => assigned
2008-06-13 13:11 sik0fewl Note Edited: 0000917
2008-07-16 11:14 WolfgangB Relationship added has duplicate 0000372
2008-07-16 13:10 mathnerd314 Note Added: 0000937
2010-04-19 00:40 mattmccutchen2 Fixed in Version 0.3.2-SVN => 0.3.3
2013-09-14 14:38 lmh Note Added: 0003519
2013-09-14 14:38 lmh Status assigned => resolved


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker