SuperTux Bug Tracker
SuperTux logo


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000603supertuxTranslationspublic2010-03-16 07:182012-09-08 06:08
Reporterbrunus 
Assigned Tomathnerd314 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86 (Intel, 32-bit)OSMac OS XOS Version10.5 (Leopard)
Product Version0.3.3 
Target VersionFixed in Version0.3.3-SVN 
Summary0000603: No translations
DescriptionWhen i select language from menu, nothing happens.
Additional Informationmy system language is polish
TagsAttachedFiles
Fixed in GIT revision
Fixed in subversion revision6691
Attached Filespatch file icon polish.patch [^] (1,172 bytes) 2011-05-23 02:15 [Show Content]
patch file icon polish-best.patch [^] (5,126 bytes) 2011-05-23 02:44 [Show Content]

- Relationships

-  Notes
(0001767)
octo (administrator)
2010-03-16 07:25

Hi, can you please describe the problem in more detail? What exactly do you select? The menu entry "Select language" in the "Preferences" menu? How do you select that, with the mouse, the keyboard or a joystick / gamepad? What do you mean by "nothing happens"? What version of SDL do you use? Regards, -octo
(0001770)
brunus (reporter)
2010-03-16 07:46

It looks like the option is selected but the game language stays english.
(0001771)
brunus (reporter)
2010-03-16 07:47

And i use sdl from darwinports.
(0001773)
mathnerd314 (administrator)
2010-03-16 14:30

Try restarting ST after changing the language.
(0001786)
brunus (reporter)
2010-03-17 09:24

Doesn’t work. The game is still english.
(0001797)
brunus (reporter)
2010-03-22 06:22

Also, this bug happens in 0.3.3 for windows.
(0001811)
brunus (reporter)
2010-03-29 06:15

In my opinion it has nothing with sdl.
(0001854)
brunus (reporter)
2010-04-24 03:10

Now some translations work, but not polish.
(0001857)
brunus (reporter)
2010-04-27 07:12

There’s definitely something wrong with the pl.po file. Could someone please check it?
(0002429)
giby (administrator)
2011-05-23 02:19

Apply this patch ;) This bug only exist on Mac, and polish is working without any problem on linux...

Once this patch applied, you should proof read it, Even if I cannot speack polish, I can see there is some polish specific vernacular that are not conserve.
Then once it is done and working.You should improve polish translation editing the file /data/local/pl.po
(0002433)
mathnerd314 (administrator)
2011-05-23 11:06

Committed polish-best.patch to SVN.

- Issue History
Date Modified Username Field Change
2010-03-16 07:18 brunus New Issue
2010-03-16 07:25 octo Note Added: 0001767
2010-03-16 07:46 brunus Note Added: 0001769
2010-03-16 07:46 brunus Note Added: 0001770
2010-03-16 07:47 brunus Note Added: 0001771
2010-03-16 14:30 mathnerd314 Note Added: 0001773
2010-03-16 15:39 mattmccutchen2 Note Deleted: 0001769
2010-03-17 09:24 brunus Note Added: 0001786
2010-03-22 06:22 brunus Note Added: 0001797
2010-03-29 06:15 brunus Note Added: 0001811
2010-04-24 03:10 brunus Note Added: 0001854
2010-04-27 07:12 brunus Note Added: 0001857
2011-05-23 02:15 giby File Added: polish.patch
2011-05-23 02:19 giby Note Added: 0002429
2011-05-23 02:42 giby Issue Monitored: giby
2011-05-23 02:44 giby File Added: polish-best.patch
2011-05-23 11:06 mathnerd314 Fixed in subversion revision => 6691
2011-05-23 11:06 mathnerd314 Note Added: 0002433
2011-05-23 11:06 mathnerd314 Status new => resolved
2011-05-23 11:06 mathnerd314 Fixed in Version => 0.3.3-SVN
2011-05-23 11:06 mathnerd314 Resolution open => fixed
2011-05-23 11:06 mathnerd314 Assigned To => mathnerd314
2011-10-22 15:28 sik0fewl Status resolved => closed
2012-09-08 06:08 superdev Tag Attached: AttachedFiles


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker