SuperTux Bug Tracker
SuperTux logo


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000799supertux-contribLevels and worldmapspublic2011-05-05 10:202013-08-18 15:00
Reportertreskalle 
Assigned Tolmh 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Summary0000799: Add-on worldmap "Island of Moob" (beta)
DescriptionAn add-on worldmap with the name "Island of Moob". It's not finished right now, but playable. Please play it and say what you think about it.
Attached zipfile can be added to the add-on repository or whatever it is, but remember that I will post the finished version when it's ready.
Additional InformationHow to install: Simply copy it to /home/username/.supertux2 (Linux, Ctrl+H shows hidden files) or C:/Documents and Settings/username/supertux2 (Windows (XP)).
DO NOT EXTRACT IT!
TagsAttachedFiles
Attached Fileszip file icon moob-island.zip [^] (41,865 bytes) 2011-05-05 10:20
zip file icon moob-island-beta2.zip [^] (49,268 bytes) 2011-05-12 09:53
zip file icon moob-island-beta3.zip [^] (2,246,665 bytes) 2011-05-13 09:42
zip file icon moob-island-beta4.zip [^] (2,244,391 bytes) 2011-05-15 10:32
zip file icon moob-island-beta5.zip [^] (2,259,974 bytes) 2011-06-21 06:36
zip file icon moob-island-beta6.zip [^] (2,276,528 bytes) 2012-02-19 05:54
zip file icon moob-island-beta7.zip [^] (2,306,213 bytes) 2013-07-23 04:32

- Relationships
parent of 0000928resolvedlmh New level "769: Antarctic Eye" 

-  Notes
(0002392)
treskalle (reporter)
2011-05-11 07:35

The 'bug' in the first level (cannon on top of MoobBot) is fixed, but this level will maybe be replaced by another one. I will (if I find it necessary) publish the worldmap in it's current state now (if I find an option to delete an attachment).
(0002395)
sK1LL (reporter)
2011-05-11 09:01

No need to delete the attachment just rename the new one to "moob-island v2.zip" thats how I do it :).
(0002398)
treskalle (reporter)
2011-05-12 07:59

No, I think "moob-island-beta2.zip" is a better name. But please not include other elements than letters, digits, - and _ in file names, if you use anything else it will be quite difficult to use the file name in a terminal/command-line.
(0002400)
treskalle (reporter)
2011-05-12 09:54

New version added.
Changes:
Fixed bug in the first level.
Added three levels, one of them secret.
Fixed other bugs.
(0002406)
lmh (administrator)
2011-05-12 19:18

I like how clean your levels are- you took the time to make them look nice and didn't use out-of-place tiles/elements. I also liked how you didn't resort to unrelenting over-the-top difficult situations to make a challenge. That third floor on the tower had my teeth grinding a bit (it's harder when big), but to be expected on a boss level. Most of the other levels were pretty easy, but it looks like you're still filling in the later content (so to be expected).

I did find one bug on "Crossing The River" if Tux is big you can trigger the first secret area without actually reaching it.

I felt things were a bit coin-heavy, which might be fine if your intention was to use coins as an object of collection. There is certainly no worry about running out of coins.
(0002407)
treskalle (reporter)
2011-05-13 07:18

lmh: Thanks for the compliments. The bug in "Crossing the River" is fixed by resizing the secret area. The third floor of "Tower of Moob" has got a reset point to decrease the frustration. In the worldmap, "place" in "You found a secret place!" has been renamed to "area" (I used "place" because I use ST with Norwegian translation, and "area" was translated to "plass", "place" in English...). Anyway, please remember that this is work in progress, and that I will release the changes described above in beta 3.
PS: Has someone found the secret places, or was it too difficult?
(0002408)
treskalle (reporter)
2011-05-13 07:18

Edit: Secret AREA in the last sentence...
(0002409)
sK1LL (reporter)
2011-05-13 07:57

Of course I have found all of them :D (the "are you drunk?" joke is funny ^^)
(0002410)
treskalle (reporter)
2011-05-13 09:40

"Are you drunk?" joke!? It's no message that says that on my worldmap...
Anyway, I can't upload the third beta because it's too big, so please wait...
(0002411)
treskalle (reporter)
2011-05-13 09:44

Deleted unused music file from the zipfile, now it's uploaded.
Changes:
New intro
New level
Some minor bug fixes/cleanup
(0002413)
hume2 (administrator)
2011-05-14 07:15

New musics? This is a way to hell. Undo it while you can!
(0002414)
hume2 (administrator)
2011-05-14 07:19

You mustn't using foreground tiles on background (only in secret areas). Use foreground tiles on foreground and background tiles on background.
(0002415)
treskalle (reporter)
2011-05-15 09:32

Hume2's first note: Not new music, but the music files included in the zipfile is music not included in 0.3.3. Airship.ogg (after 0.3.3) and ji_turn.it (music found in ST version 0.0.x, not included in later versions) is included in beta 3. Battle_theme.ogg was removed to make the zipfile small enough to be an attachment, and because I haven't planned to use it.
Hume2's second note: What do you mean?
(0002416)
treskalle (reporter)
2011-05-15 10:35

Beta 4 released.
Changes:
Deleted ji_turn.it because it doesn't work with OpenAL.
Added useful secret level.
Added second moat level.
Messages in the worldmap now only works in one direction.
(0002417)
hume2 (administrator)
2011-05-15 12:10

Use solid tiles only in solid layers.
(0002418)
treskalle (reporter)
2011-05-16 04:42

Hume2: Why?
(0002419)
hume2 (administrator)
2011-05-16 05:19

Darksnow tiles are SOLID, then use darksnow tiles only in solid layers.
(0002420)
treskalle (reporter)
2011-05-19 08:48

Why only in solid layers? Why can't level designers choose their tiles self? Why are you writing notes like that when you are doing it yourself?
Anyway, I thought that the darksnow tiles could be used for holes like the hole tiles in the forest catgory.
(Sorry for the eventually bad english...)
(0002424)
hume2 (administrator)
2011-05-20 07:15

If this is a demonstration of playable levels then the player should at first know where he can safely grow. There are not used darksnow tiles in forest.
(0002425)
treskalle (reporter)
2011-05-20 07:28

I'm not saying that darksnow tiles exists in forest. I think that the darksnow tiles is in so big contrast to the normal snow tiles that the player understands that this is holes.
(0002428)
hume2 (administrator)
2011-05-21 08:43

I confess that I don't understood it until I fell into one.
(0002435)
treskalle (reporter)
2011-05-24 06:16

hume2: Please read the infoblocks in the first level.
(0002436)
hume2 (administrator)
2011-05-25 11:53

There is nothing about it.
(0002438)
treskalle (reporter)
2011-05-28 06:17

hume2: It is something about it. Read the infoblock before the MoobPit in the first level.
(0002440)
hume2 (administrator)
2011-05-29 21:51

What if I forget it?
(0002448)
treskalle (reporter)
2011-06-21 06:40

Beta 5 released.
WARNING: I forgot to test it before I uploaded it. Please report if there are any critical bugs.
Changes:
Three or more levels added
Other things that i cannot remember...
(0002449)
treskalle (reporter)
2011-06-21 06:54

Discovered a bug...
I do not want to upload the fixed version now.
You can fix the bug by opening the file worldmap.stwm in the zipfile, and change "levels/mount-iceshrub.stl.stl" to "levels/mount-iceshrub.stl".
I'm sorry, but I forgot to test it before I uploaded it.
(0002451)
hume2 (administrator)
2011-06-24 04:48

How many beta versions you going to relase until you relase a full version?
(0002566)
treskalle (reporter)
2011-08-30 02:06

hume2: I do not know.
(0003086)
treskalle (reporter)
2012-02-19 06:00

The sixth (and maybe last) beta is released.
Changes:
Some new levels added, new text in the IBs in the first level, and a few other changes.
Please report every bug you may discover.

I'm not willing to continue this project, someone can continue it if they want to.
Please add the worldmap to the addons, I'm sure it's stable enough.
(0003087)
ctdabomb (administrator)
2012-02-19 13:59

nice improvements. though I couldn't get past the angry stones in the submarine level :(
(0003101)
treskalle (reporter)
2012-02-20 08:44

ctdabomb: I'll give you a clue: Wait.
(Maybe I should remove the angry stones and replace them with another badguy?)
(0003102)
lmh (administrator)
2012-02-20 16:43

I'm sorry to hear that you're likely to discontinue the project- it has been a fairly popular download from the add-on collection I put together.

On another note, I've been collecting random levels from the bugtracker for a worldmap and found several that you had uploaded earlier (see bug 0000915). They all lack any licensing, and I was wondering if you'd want them under the same license as you used here (GPL 2+ / CC-by-sa 3.0). Let me know if you want to add a license (or have me do it for you). I think it would aid in making the levels more distributable, but the choice is yours.
(0003105)
treskalle (reporter)
2012-02-22 08:33

lmh:
1. I'm making a level (named "769: Antarctic Eye") now, which will be included in the IoM. The IoM project will continue if I have time enough.
2. Yes, the levels should be distributed under the GPL 2+/CC-by-sa 3.0. (But is the levels "Deep,deeper" and "Deepest" one of them?)
(0003106)
ctdabomb (administrator)
2012-02-22 09:18

"Deep,deeper" and "Deepest" has been uploaded to the tracker, but it is not in the worldmap LMH made.
(0003115)
lmh (administrator)
2012-02-24 10:52

I recall the levels, but I seem to have missed them in my recent survey. Which bug number are they in?
(0003250)
lmh (administrator)
2012-12-20 13:49

This addon is accessible via the Addon Manager in GIT revision 947098af8085
(0003376)
treskalle (reporter)
2013-07-23 04:58

This is probably going to be my last post here in the Supertux Bug Tracker.

I am, most likely, NOT going to expand this worldmap anymore, partly because I have other interests, partly bcuz I don't have the level editor anymore (too lazy to compile it :D), and partly because I am too bad in finishing a project...
Since I've released the map with a free license, everyone's able to finish it if you want.

I have uploaded the last update to this map, which include a couple of new levels, an epilogue and some ugly (?) eyecandy on the worldmap.
This will probably be my last contribution to Supertux. I'm sorry for cancelling this project.

Then it's time to say:
So long, and thanks for all the fish (maybe herring?)

PS: Sorry for my bad english, but at least it has improved a lot since my first post here. The grammar in the worldmap hasn't been improved, though...
(0003381)
lmh (administrator)
2013-08-07 15:20

I wouldn't worry too much about leaving your map incomplete- it does not seem to be a very big crime in this project. Sorry to see you go, but I understand. I will go through and update your add-on.

- Issue History
Date Modified Username Field Change
2011-05-05 10:20 treskalle New Issue
2011-05-05 10:20 treskalle File Added: moob-island.zip
2011-05-11 07:35 treskalle Note Added: 0002392
2011-05-11 07:36 treskalle Issue Monitored: treskalle
2011-05-11 07:36 treskalle Issue End Monitor: treskalle
2011-05-11 09:01 sK1LL Note Added: 0002395
2011-05-12 07:59 treskalle Note Added: 0002398
2011-05-12 09:53 treskalle File Added: moob-island-beta2.zip
2011-05-12 09:54 treskalle Note Added: 0002400
2011-05-12 19:18 lmh Note Added: 0002406
2011-05-13 07:18 treskalle Note Added: 0002407
2011-05-13 07:18 treskalle Note Added: 0002408
2011-05-13 07:57 sK1LL Note Added: 0002409
2011-05-13 09:40 treskalle Note Added: 0002410
2011-05-13 09:42 treskalle File Added: moob-island-beta3.zip
2011-05-13 09:44 treskalle Note Added: 0002411
2011-05-14 07:15 hume2 Note Added: 0002413
2011-05-14 07:19 hume2 Note Added: 0002414
2011-05-15 09:32 treskalle Note Added: 0002415
2011-05-15 10:32 treskalle File Added: moob-island-beta4.zip
2011-05-15 10:35 treskalle Note Added: 0002416
2011-05-15 12:10 hume2 Note Added: 0002417
2011-05-16 04:42 treskalle Note Added: 0002418
2011-05-16 05:19 hume2 Note Added: 0002419
2011-05-19 08:48 treskalle Note Added: 0002420
2011-05-20 07:15 hume2 Note Added: 0002424
2011-05-20 07:28 treskalle Note Added: 0002425
2011-05-21 08:43 hume2 Note Added: 0002428
2011-05-24 06:16 treskalle Note Added: 0002435
2011-05-25 11:53 hume2 Note Added: 0002436
2011-05-28 06:17 treskalle Note Added: 0002438
2011-05-29 21:51 hume2 Note Added: 0002440
2011-06-21 06:36 treskalle File Added: moob-island-beta5.zip
2011-06-21 06:40 treskalle Note Added: 0002448
2011-06-21 06:54 treskalle Note Added: 0002449
2011-06-24 04:48 hume2 Note Added: 0002451
2011-08-30 02:06 treskalle Note Added: 0002566
2011-10-23 09:57 sik0fewl Project supertux => supertux-contrib
2012-02-19 05:54 treskalle File Added: moob-island-beta6.zip
2012-02-19 06:00 treskalle Note Added: 0003086
2012-02-19 13:59 ctdabomb Note Added: 0003087
2012-02-20 08:44 treskalle Note Added: 0003101
2012-02-20 16:43 lmh Note Added: 0003102
2012-02-22 08:33 treskalle Note Added: 0003105
2012-02-22 09:18 ctdabomb Note Added: 0003106
2012-02-24 10:50 lmh Relationship added parent of 0000928
2012-02-24 10:52 lmh Note Added: 0003115
2012-09-08 06:16 superdev Tag Attached: AttachedFiles
2012-12-20 13:49 lmh Note Added: 0003250
2012-12-20 13:49 lmh Status new => resolved
2012-12-20 13:49 lmh Resolution open => fixed
2012-12-20 13:49 lmh Assigned To => lmh
2013-07-23 04:32 treskalle File Added: moob-island-beta7.zip
2013-07-23 04:58 treskalle Note Added: 0003376
2013-08-07 15:20 lmh Status resolved => assigned
2013-08-07 15:20 lmh Category Levels and Worldmaps => Levels and worldmaps
2013-08-07 15:20 lmh Note Added: 0003381
2013-08-18 15:00 lmh Status assigned => resolved


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker