This wiki has been moved to https://github.com/SuperTux/wiki into the mediawiki branch.

Talk:Building on Windows

From SuperTux
Revision as of 13:37, 6 July 2011 by Q (Talk | contribs)

Jump to: navigation, search

gcc-g++ package needed

I had to install one additional package in order to get SuperTux to compile -- the MinGW gcc-g++ package for compiling C++ code, found here. - Sik0fewl

libcurl missing?

When I want to compile SuperTux on windows xp, i get an error because the sourcefile addon_manager.cpp needs LIBCURL... but i don't know where i can find the right LIBCURL-package for windows and how to install it (with MSYS ...) please update this page.. - TowelieDasTuch

Note that we don't have a windows maintainer and most developers have better things to do than rebooting to windows. Motivation is a bit low to keep stuff compiling on windows just for the sake of other people playing svn versions... Basically: Please try a little harder fixing it yourself! --MatzeB 20:34, 29 January 2007 (UTC)

By the way - libcurl shouldn't be needed to compile SuperTux. You can safely remove the check for libcurl from the autoconf scripts (just go back a few SVN revisions) and SuperTux should build just fine. Send us a patch if you can change the autoconf scripts to make it truly optional. --Sommer 21:37, 29 January 2007 (UTC)

DLLs needed

SuperTux seems to run fine with only the following DLLs in place

  • libogg-0.dll
  • libphysfs-1-0-0.dll
  • SDL.dll
  • SDL_image.dll

Further investigation necessary

Install SDL

Hi, I have no idea how to install SDL .. I don't know what to do after unpacking the SDL-package ... please help me =)

Wine

Just for fun I ran Supertux 0.3.1 in Wine. The installer worked all right, supertux2.exe runs but it is too slow to be fun. It is faster than SDL-Mode but still too slow. On my machine Supertux works fine when playing the native version. No idea what went wrong here, other games run in Wine just a bit slower or even as fast as in Windows but not Supertux. Not a real problem from me but maybe the windows port has some problems?